单片机论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 290|回复: 1
收起左侧

TM1650+msp430单片机 调试及遇到问题的总结

[复制链接]
baogang 发表于 2019-9-16 21:01 | 显示全部楼层 |阅读模式
本帖最后由 baogang 于 2019-9-23 10:36 编辑

最近做了用到三个tm1650及msp430f149项目,其中还涉及到其他的一大堆东西,在这里就不一一说了,这里主要分享一下TM1650调试过程中遇到的问题和解决的办法。仅供大家参考。

首先,先描述一下问题,在调试这个项目之初,先用在某宝买的tm1650带按键和数码管显示的模块,调程序的时候,没有遇到任何问题,非常顺利。用了I2C总线,也很顺利。然后就去自己画了合适尺寸的PCB,买元件,焊接。和电路板连接,上电。
然而神奇的事情发生了,新做的tm1650板子不亮。如何都不亮,又连接了某宝的模块,分分钟正常亮起来。

搞的我有点怀疑自己的电路和焊接,本人焊接水平本来就一般。
然后疯狂的检查电路板的焊接有没有问题,左查右查,一直找不到问题。用表一个个的检查了,也查不到任何问题。
就又焊接了好几块,然后发现只有一块亮,其他的都不亮,我心里想着只要有一块能亮,就不是电路的问题。而且焊接的问题,于是找了个哥们,帮忙焊接了几块,依然是不亮。最终用烙铁左试试右试试,最终是捣鼓了三块亮的,想着不管如何,样机是够用了,此时从来没有怀疑其他的问题。样机装完之后,等着今天发出去,今天下午发出去之前,想着上电再试一下,谁知道这一试之下,有一个1650完全不亮了,想着中秋节加班的时候,明明都是OK的呀。一下子就头大了。

然后疯狂的重新捣鼓其他的数码管,发现依旧都不亮,在别的接口上是好的数码管,接到这个上面之后就不亮了,无论如何都不亮。
简直就要在原地爆炸了。

安静下来想了想可能存在问题的地方:
1.会不会是单片机IO的问题?换过来的TM1650不亮,但是接到别的IO口上是可以亮;怀疑IO口问题,用示波器测了一下,IO电平正常,符合I2C的电平,且与其他IO的电平一致。这个问题排除。
2.TM1650的问题?查了又查,怀疑是TM1650的问题,但是在别的IO口上可以亮,但是有时候不一定会亮。这个问题是有可能的。
3.TM1650与单片机连接线的问题。因为板子对体积有比较严格的要求,所以选的PH-1.25的插头,连接线也是在某宝买的,不知道是不是线的问题?用万用表测试之后,线没有问题,是正常的。可能性排除。
4.可能是其他某些未知的玄学原因;说不清,很难讲。

再排除问题的过程中,用的直流电源直接测试的过程中,因为直流电源输出没有设置好,所以直接调到0V,然后拨到24V。然后奇幻的事情发生了,再缓慢升压的过程中,一直不亮的TM1650亮了。再重新测试,直接上24V电压,M1650又不亮了。

问题找到了。找到问题就知道怎么解决了。

问题解决:
1.怀疑是电容选的不对,在缓慢升压的过程中,电容缓慢充电,系统可以正常工作。更换了较小的电容,但是结果仍然是一样。缓慢上电没问题,直接上电不亮。
2.单片机发送的初始化信号,TM1650硬件可能还没有初始化完成。修改程序即可。在程序检查的过程中,发现了这个不亮的这块,在程序中是最先初始化的。找到了出问题的地方。

在第一块点亮的TM1650的初始化之前加了20ms的延时。
正常。问题解决了。

【问题总结】

这次这个问题确实比较难以发现,因为刚刚开始有一块板子是可以亮的,所以一直没有往这个方向考虑这个问题。最终发现了问题,才知道如何解决。如果非要说,可能说跟tm1650的体制有关吧,要不第一块是怎么亮的。
现在来总结这个问题的话,还是习惯问题,而且论坛里面真的有大神给过提醒。
传送门:http://www.btr8get.com/bbs/dpj-169689-1.html


希望大家在调试1650的时候,注意这些问题,少走些弯路。

评分

参与人数 1黑币 +90 收起 理由
admin + 90 共享资料的黑币奖励!

查看全部评分

回复

使用道具 举报

51hei团团 发表于 2019-9-23 15:21 | 显示全部楼层
谢谢分享,好资料
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|单片机论坛 |51黑电子论坛技术交流 QQ 管理员QQ:125739409;技术交流QQ群636986012

Powered by 单片机教程网

快速回复 返回顶部 返回列表
妞干网免费观看频2018